Support Forum

Add Post
Add Post
Subject:
Nickname:
Content:
Email:
Message
Date & Time
searching more than one plugin Rachel
10.02.14
searching more than one plugin
By: Rachel
Is there a way to use looprows (or loopget) for more than one plugin?
for example to create a search box which searches both articles and blog posts
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
how to clear\reset the cache? Idan
3.02.14
how to clear\reset the cache?
By: Idan
Hi, the magma saved the css configuration in cache files and it don't changes it after i have changed the css files how to reset it to the new css data ?
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
how to clear\reset the cache? Ariel
3.02.14
how to clear\reset the cache?
By: Ariel
Well first of all when in developer mode you see the site without cache,
should you want to clear cache anyway here's what to do:
in the "Apps" activate "Beta Mode".
Then you have a new icon "tool box", press it
Then you'll see a button "Clean all cache", guess what is does.
It is highly recommended not to clean cache to avoid server overload for no reason.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using looprows two times in one page Idan
3.02.14
using looprows two times in one page
By: Idan
How to reset to looprows function so I can use it two times in the same page?
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using looprows two times in one page Ariel
3.02.14
using looprows two times in one page
By: Ariel
There is no need to reset the looprows, It's a function not a variable...
Post some code I'm interested.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
2 things Rachel
21.01.14
2 things
By: Rachel
1. Looprows doesn't work when I have both dateformat and join in the array (it works fine with dateformat and it works fine with join but doesn't work with both of them together)

2. I have a plugin which has only one row in it but it keeps automatically adding more empty rows even though I have set the limit to one - this only happens with one of my plugins, the rest work fine
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
2 things Ariel
21.01.14
2 things
By: Ariel
Hi Racehl,

could you post the code for us?
It should look like this
while(looprows('someloop', Array('dateformat_date' => '%d.%m.%Y', 'join_anotherloop' => true))) {
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
2 things Rachel
21.01.14
2 things
By: Rachel
while(looprows('newsdates', Array(
'dateformat_date' => '%d.%m',
'join_newsitems' => true
))){
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
2 things Ariel
21.01.14
2 things
By: Ariel
Hi Rachel,

The source of the problem isn't dateformat with join but the loop that holds the current loop.
you are trying to join the loop that holds your current loop, which you can' t and also you shouldn't. you can use any of the fields of the holding loop inside the inner loop, without the need of join.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Js/css Rachel
19.01.14
Js/css
By: Rachel
How can I add css or js files which are just for some browsers?
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Js/css Ariel
19.01.14
Js/css
By: Ariel
Well there are several ways, it depends on the result.
the basic syntax in @media follows by one of the following:
screen/(max-width:420px)/(min-width:420px) and alikes of it,
you can read further at:
here


and here
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Js/css Rachel
19.01.14
Js/css
By: Rachel
I was actually trying to ask how I can add code that I would usually put in the head since the head is generated by the system

eg

Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Js/css Rachel
19.01.14
Js/css
By: Rachel
[if (gt IE 9)|!(IE)]
script src="js/jquery.mobile.customized.min.js" /script
[endif]
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Js/css Ariel
19.01.14
Js/css
By: Ariel
You can create a new part called "in_header.php" which will be added to the head part of the page
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Fix my last post :) Lior Nagar
15.01.14
Fix my last post :)
By: Lior Nagar
//while(looprows('pluginName')){

}
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
loop things Ariel
15.01.14
loop things
By: Ariel
Just to make sure I got it right.
if you want to use a variable for the loop you should use

foreach(loopget('someloop') as $some_loop {
for($i = 1 ; $i < 15; $i++) {
Some code
}
}

If you wish to count the number of objects there is a better way:

$loop_count = count(reset(loopget('some_loop')));
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
loop things Lior Nagar
15.01.14
loop things
By: Lior Nagar
Works great, thanks!
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
loop things Lior Nagar
11.01.14
loop things
By: Lior Nagar
The loop killes variables ...
For example if I want to create a Counter I do something like this:

$ counter = 0;

     echo $counter;
      $ counter + +;


in this case the counter return 0 all the time.

Another thing, sometimes I want to get the content out of the loop and use it (Not echo)
There must be something to it
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
auto load css does not work Idan
13.01.14
auto load css does not work
By: Idan
I'm trying to use the auto load of css (using the folder css/all) but when I do so i get multiple error for the path (404)
Failed to load resource: the server responded with a status of 404 (Not Found) http://212.199.177.217/idan/site_1/design/default/css/css/skeleton.css
Failed to load resource: the server responded with a status of 404 (Not Found) http://212.199.177.217/idan/site_1/design/default/css/css/superfish.css
it shell be css/all instead of css/css ..
* some of the files are load successfully but i cant tell which once because it calls multiple times to the same file with different GET variable..
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
auto load css does not work Ariel
13.01.14
auto load css does not work
By: Ariel
Well first of all to debug correctly you could add
body{
background:red !important;
}
to each css and see which ones aren't loaded
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
First and Last run of looprows Idan
21.01.14
First and Last run of looprows
By: Idan
in the documentation if saw only the [[first]] && [[last]] operators, they are just not enough.. i don't want to add class, i need a full line to be written or not to be written.. I cant just display none ul tag.. it doesn't work..
and generally its makes the development very uncomfortable when I cant access the variables with PHP to check them, how may i do it (for an example to check which of the titles in the top menu is the cur page..)
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
First and Last run of looprows Ariel
21.01.14
First and Last run of looprows
By: Ariel
Hi idan,

I'm afraid I didn't fully understand your question, what use are you seeking to do with the first/last object, give me an example please
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
POST \ GET requests via form Idan
13.01.14
POST \ GET requests via form
By: Idan
when you send a post from a form the looprows do not run (or run but do not print.. )
when i create get request via the url it works fine.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
POST \ GET requests via form Ariel
13.01.14
POST \ GET requests via form
By: Ariel
Do you have an fpage(a page to which the user is transferred when he has completed the form\ an iframe with src="default.empty" which the form is targeted to?
You must have one of the two
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
deleting plugin Idan
19.01.14
deleting plugin
By: Idan
The delete button for plugins do not work.
when you refresh the page the plugin returns.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
deleting plugin Ariel
19.01.14
deleting plugin
By: Ariel
Yes plugins are a bit of hard asses when it comes to deleting.
It's actually a fail-safe mechanism, so to make sure there's no accidental deleting of plugins. what you need to do is delete the folder of the plugin first, then delete the plugin in the plugin maker.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
cant delete plugins Idan
19.01.14
cant delete plugins
By: Idan
I do not have permission to delete the folder...
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
cant delete plugins Ariel
19.01.14
cant delete plugins
By: Ariel
You can hide them from the Magma toolbar
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using [[link]] as PHP variable Idan
19.01.14
using [[link]] as PHP variable
By: Idan
Hi,
I need to use the [[link]] var as a PHP var for an IF statment, how shell I do it ?
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using [[link]] as PHP variable Ariel
19.01.14
using [[link]] as PHP variable
By: Ariel
Well the syntax is like the exmaple:


and you can also use:


which helps preventing dead links and giving headers for menus and submenus
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using [[link]] as PHP variable Idan
19.01.14
using [[link]] as PHP variable
By: Idan
I need to check if link is equal to $_SERVER["REQUEST_URI"] not if its exists (to add current class to the top menu li )
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
using [[link]] as PHP variable Ariel
19.01.14
using [[link]] as PHP variable
By: Ariel
Well in that case you can only do it with loopget,
looprows is a templating function that creates the HTML that is shown in the page.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
תקלות קרטיות שמצאתי עד כה Lior Nager
9.01.14
תקלות קרטיות שמצאתי עד כה
By: Lior Nager
1) עורך תוכן באיזור אדמין לא מעדכן תוכן,כותב תמיד admin.pluginname.
2) קבצי js לא נטענים ב-fireFox,לא נוצרים לינקים לקבצים ב- .
3) מדי פעם ה- plugin-maker וה-bg-dev נעלמים מאיזור האדמין (למעלה בצד שמאל).
מופיעים שוב כאשר מוחקים cache של הבראוזר.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
הערה נוספת Lior Nager
9.01.14
הערה נוספת
By: Lior Nager
עד שיתוקן העניין של העורך תוכן, אני מזין תוכן ישר לתוך הדאטאבייס.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
developer mode login Idan
9.01.14
developer mode login
By: Idan
I can't login to developer mode.
I wrote the right password,
What shell i do?
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
use dev-password maker Ram
9.01.14
use dev-password maker
By: Ram
To use dev-password maker,
1. Open the config file (usually: configs/default.php)
2. Comment the line that contains "DEVPASS" (with // at the start of the line)
3. Put "dev.start" in your URL address or click on "Developer login" in the "APPS" section
4. Enter your desired password at the shown input, and submit
5. The system will generate a line of code, copy this line to your config file (configs/default.php)
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Idan Worked like a charm
9.01.14
Idan
By: Worked like a charm
Thanks
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
menu does not work Nechemya
9.01.14
menu does not work
By: Nechemya
No matter what I do, everything is written correctly but the code and managing the site does not display MENU
I dug it more than an hour and a half ..

Add, modify, re-create

Nothing!!!

Help brass .....

Thank Nehemiah.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Re: Ram
9.01.14
Re:
By: Ram
Please savee the menu and submenu plugins again by clicking on "save plugin"
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Fixed Nechemya
9.01.14
Fixed
By: Nechemya
Now the menu works.
10x
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
The requested URL /vital/13.11/dev.start was not found on this server. Elya
7.01.14
The requested URL /vital/13.11/dev.start was not found on this server.
By: Elya
I've installed the magma on my localhost succefully and got the link:
Successfully Installed!
Go to developer mode
But unfourtunatly when when I click the link I got this message:
Not Found
The requested URL /vital/13.11/dev.start was not found on this server.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Re: Ram
7.01.14
Re:
By: Ram
Try install it on a linux machine.
For now the system doesn't support windows as a server.
You can mount the server as local file system using tools like this one:
https://code.google.com/p/win-sshfs/
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
The system wont start Idan
7.01.14
The system wont start
By: Idan
Hi,
I have tried to do the installation of the magma SDK on my localhost and on the server, on the local host I've got the following error :
Strict standards: Only variables should be passed by reference in C:\xampp\htdocs\simple_site_1\load_box.php on line 16
its not a critical problem (i think) but it is a problem..
when I try to enter the installation on the server I just get an empty page (it prints "hello world" on echo.. )
please check if the system that currently on the server is the newest and that its functional :)

p.s
the folder got 777 permissions and the system was uploaded as .7z file and un-archived via SSH.
please keep me up to date,
Idan
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Re: Ram
7.01.14
Re:
By: Ram
The system is running on "linux" systems only at the moment.
At the next releases we will work to set it to work on windows as well.
Please upload the code to a linux server for now instead of working on a local machine.
You can mount the server as local file system using tools like this one:
https://code.google.com/p/win-sshfs/
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Good luck pucho
13.05.13
Good luck
By: pucho
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
First post Forum Manager
12.05.13
First post
By: Forum Manager
Hi,
Welcome to the new forum of magma.
We here to help you with all questions about magma.
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email:
Thanks :) ram
7.04.13
Thanks :)
By: ram
Add Comment
Add Comment
Subject:
Nickname:
Content:
Email: